Incident Awareness Update from Zepto - PayID maintenance and Account registrations
Incident Report for Zepto Payments AU
Resolved
This incident has been resolved.
Posted Nov 21, 2024 - 15:07 AEDT
Investigating
Dear Valued Zepto Customer,

Our Financial Institution has detected technical difficulties, affecting PayID maintenance and account registrations.

They are investigating this incident as a priority and will provide a further update within an hour.
Posted Nov 21, 2024 - 14:07 AEDT
This incident affected: Zepto API (Australia [API]), System Components (Australia [System Components]), and NPP Services (PayID Services).