Incident Awareness from Zepto

Incident Report for Zepto Payments AU

Resolved

This incident has been resolved.
Posted Aug 31, 2026 - 18:33 AEST

Update

We experienced elevated database resource utilisation which resulted in degraded service performance.

A fix has been deployed and real-time notifications have resumed for new webhooks and API endpoints.

Components still affected:
• Confirmation of Payee batch processing — delayed
• CSV uploads — delayed

Our teams are working to restore normal processing for these services and clear the remaining queues. We'll provide a further update shortly.
Posted Aug 31, 2026 - 18:00 AEST

Identified

We have identified the cause of the delays.

Your payments are continuing to process normally. The issue affects how quickly those payments are reflected back to you — transaction statuses and event notifications may be delayed or slow to appear in your dashboard, in API responses, and via webhooks.

Affected components:
• Zepto Dashboard (UI) — degraded performance
• API — degraded performance
• Webhooks — degraded performance

Our teams are working to restore normal update times and clear the backlog. We'll provide a further update shortly.
Posted Aug 31, 2026 - 16:47 AEST

Investigating

We’re currently investigating delays affecting real-time webhooks and event processing. Merchants may experience delays in receiving updates.

Our teams are actively working to restore normal processing and reduce the backlog. We’ll provide a further update as soon as possible.
Posted Aug 31, 2026 - 16:21 AEST
This incident affected: Zepto API (Australia [API]), System Components (Webhooks), and User Interface.